Back to overview
Downtime
SightCall console is inaccessible
Nov 30 at 03:55pm UTC
Affected services
SightCall EU Platform
SightCall US Platform
Resolved
Nov 30 at 04:12pm UTC
The service has been restored. Thanks for your understanding
Affected services
SightCall EU Platform
SightCall US Platform
Created
Nov 30 at 03:55pm UTC
We are currently experiencing an outage preventing access to the SightCall console. We are investigating the matter and will provide an update shortly.
Affected services
SightCall EU Platform
SightCall US Platform