Back to overview
Downtime
2022-02-25: US Console unavailable
Feb 25 at 10:42am UTC
Affected services
SightCall US Platform
Resolved
Feb 25 at 02:25pm UTC
Identified the root cause and resolved the issue
Affected services
SightCall US Platform
Created
Feb 25 at 10:42am UTC
Agents are not able to connect in Salesforce
Affected services
SightCall US Platform