Back to overview
Degraded

[Retroactive Outage Post] Agent cannot log in or create new calls

Mar 18, 2026 at 09:20am UTC
Affected services
SightCall EU Platform

Resolved
Mar 18, 2026 at 09:27am UTC

All services are back to normal operations.

Created
Mar 18, 2026 at 09:20am UTC

SightCall Service hosted in Europe infrastructure is impacted by this 7 minutes outage - during this time agent cannot log in, or if logged in already, they cannot create a call.

Existing call sessions are unimpacted.