Back to overview
Downtime

[Retroactive Outage Post] Some SightCall services was not responsive / error out

Apr 13, 2026 at 2:40pm UTC
Affected services
SightCall EU Platform
SightCall US Platform

Resolved
Apr 14, 2026 at 1:21am UTC

Services are back to operational

Updated
Apr 14, 2026 at 1:10am UTC

The services (admin / console) are again down

Updated
Apr 13, 2026 at 2:53pm UTC

Issue is resolved.

Created
Apr 13, 2026 at 2:40pm UTC

Some SightCall services went down, and agent authentication and session connection may render errors.