Back to overview
Degraded
Users in Americas accessing tenants at Europe region may intermittently fails
Apr 14, 2026 at 1:00pm UTC
Affected services
SightCall EU Platform
Resolved
Apr 15, 2026 at 4:00pm UTC
services should be back to normal operation.
Affected services
Created
Apr 14, 2026 at 1:00pm UTC
Admin accessing admin portal, agents accessing console that need to authenticate may load a long time and eventually error out.
Affected services