Back to overview
Downtime

[retroactive post] Vision console/flows hosted on Europe tenants returns 'Nothing to see here'

Apr 14, 2026 at 1:20am UTC
Affected services
SightCall EU Platform

Resolved
Apr 15, 2026 at 2:00pm UTC

The issue is resolved

Created
Apr 14, 2026 at 1:20am UTC

Agent console / guest experience / custom flows are impacted - but very inconsistently. Our team is investigating.