Back to overview
Degraded

iOS App Store issue

Mar 21 at 04:44pm UTC

Resolved
Mar 21 at 05:44pm UTC

The iOS App Store seems to be available again.

Follow https://www.apple.com/support/systemstatus/ for updates

Created
Mar 21 at 04:44pm UTC

The iOS App Store seems to be unresponsive. Downloading our apps may not be possible at this time.